Angeldust

YouTube Facebook Instagram Twitter
iTunes App Store Google Play Store Steam (Windows, macOS, Linux) Windows Mac App Store

Firefly plz

in English in Forums





Post 1–5 of 5

1


OP

by

zaljo151718

3 months ago


Firefly if you could plz fix the mammoth shockwave so it cant hurt players on their plots id be greatful im on the inside of my walled in plots and every time i try to do anything the mammoths keep showing up and their shockwaves keep killing me PLZ when you get the chance this has been a nuisance since i ever started claiming land in mammoth areas and i cant stop buuilding to take like 10-15 minutes to kill them


# 2

by

Hummm

3 months ago


Try this strategy: Mammoths will come to you if you are above/higher than them. Use this to your advantage to have them "chase" you... once you are 5-6 claims away, TP back to your claim.


# 3

by

Firefly

3 months ago


Zaljo, I understand your frustration. For now, Hummm's tactic seems decent to mitigate the problem a bit. I'll put it on my list of things to think about to find a good solution.


# 4

by

Fierro

3 months ago


It happened to me while I was building the dragon's head. The first mammoth was killed. But the second one... I used Hummm's strategy and it works well. It take just a few minutes to guide the mammoth out of sight and then I could resume building.

I think it's part of the risk of building on the wild beautiful interior lands. And it worth it.


# 5

by

Kamikaze Justice

3 months ago


There are risks in the real world... why not some risks in the Angeldust world?

I actually wouldn't mind creatures spawning on my claimed land because King Kong, Godzilla, and Rodan attacking New York City was cool ;)

Maybe, we can have a switch that can turn on and off the creatures spawning on our claimed lands?


Post 1–5 of 5

1