Angeldust

YouTube Facebook Instagram Twitter
iTunes App Store Google Play Store Steam (Windows, macOS, Linux) Windows Mac App Store

Preformence issues

in English in Forums





Post 21–27 of 27

Previous « 1 2 3


# 21

by

Aoi Blue

9 months ago


The new network issue icon on the desktop version displays too easily.

I suspect it may be triggering with a single missed packet. I think it probably should require 500ms worth of packets to be lost before it triggers, as this is the point of "visible" lag, resulting in noticeable desyncing, jittering and other lag issues, instead of "just feeling laggy" which would be 20ms-100ms depending on the person's level of perception of lag and the game's lag compensation techniques.

As a note, I think you might want to add an option to the settings menu on "bandwidth usage." On the mobile version it should have two ones (WiFi and Mobile-Data). Users that know the speed of their Internet connection should be able to select it in order to improve speed.

If you want advanced options it should be divided into "Burst Downstream, Downstream and Upstream."

For instance, for my computer I would set it to 5 Mbps burst Downstream, 512 Kbps Downstream, and 512 Kbps Upstream. This is giving a generous buffer to the limits of my connection as not to disrupt network usage.

Burst upstream should be for a maximum of 5 seconds. The use of a separate burst limit allows for faster loading of buildings. It should not be used for standard synchronization of gameplay.


# 22

by

Skyline

9 months ago


No issues so far, seems to be solid at the moment. I'll let you know if it happens again.


# 23

by

Aoi Blue

9 months ago


It seems there are some significant network performance issues in latest Linux release (substantial network lag.)

I highly recommend prioritizing network functions in the game (both server and client side.) Nearby terrain and entities (i.e. monsters, other players, etc.) should be highest priority, loading far distant terrain should be lower priority. This way far view distance won't create lag.


# 24

by

Firefly

9 months ago


Aoi Blue – there are no network issues. The disks in the server are being hammered by a backup job that is running because of the software update. It'll be done soon and everything will be back to normal.


# 25

by

stonegargoyle

9 months ago


ok so the game runs fine when I'm close to the spawn in town I started in with my home spot but the further I get away the more it lags then if I go even further the framerates have the refresh go with flashing lines that go down the screen as I move but not as much if I stop moving. I'm on a windows 10 pc I turned down the detail settings this help with the lag but the flashing lines if I'm to far from my home town still remain. however if I get to another town the flashing stops and the lag seems to decrease, so it appears it happens when I'm out in the wild. unless I got turned around and just walk back into my home town lol. hope this help with figure stuff for the game.


# 26

by

412655

9 months ago


Эммм...
Пора Яндекс переводчик ставить...
Как я понел, у тебя проблема с вертикальными линиями?
Если да...
То попробуй переустановить игру...
Или настроить компьютер / смартфон...


# 27

by

Firefly

9 months ago


stonegargoyle – that's a weird bug report! Can you try toggling V-sync in the options menu? Do you have this problem with other games? Kind of sounds like VRAM corruption…


Post 21–27 of 27

Previous « 1 2 3